vendredi 6 janvier 2017

Adobe flex migration error defaults.css expected

I am having an issue migrating from adobe flex 3.3.0.4852 to 4.5.1.21328

Applying the same configuration I had it set up it throws a exception executing flexmojos-maven-plugin

<plugin>
            <groupId>org.sonatype.flexmojos</groupId>
            <artifactId>flexmojos-maven-plugin</artifactId>
            <version>3.2.0</version>
            <extensions>true</extensions>
            <executions>
                <execution>
                    <goals>
                        <goal>compile-swf</goal>
                    </goals>
                </execution>
            </executions>
            <configuration>
                <moduleFiles>
                    <module>APP_MIGRATED.mxml</module>
                </moduleFiles>
                <locales>
                    <param>en_US</param>
                </locales>
                <services>${basedir}/src/main/resources/services-config.xml</services> 
                <contextRoot>root</contextRoot>
                <keepAllTypeSelectors>true</keepAllTypeSelectors>
                <output>${basedir}/target/APP_MIGRATED.swf</output>
                <targetPlayer>9.0.0</targetPlayer>
            </configuration>
        </plugin>

The error is triying to compile the source it trows the next error

[ERROR] C:\m2_repo_clean\com\adobe\flex\framework\advancedgrids\4.5.1.21328\advancedgrids-4.5.1.21328.swc$defaults.css:[13,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\charts\4.5.1.21328\charts-4.5.1.21328.swc$defaults.css:[13,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\charts\4.5.1.21328\charts-4.5.1.21328.swc$defaults.css:[14,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\charts\4.5.1.21328\charts-4.5.1.21328.swc$defaults.css:[108,-1] Unexpected character: D. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\charts\4.5.1.21328\charts-4.5.1.21328.swc$defaults.css:[112,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\framework\4.5.1.21328\framework-4.5.1.21328.swc$defaults.css:[15,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\mx\4.5.1.21328\mx-4.5.1.21328.swc$defaults.css:[15,-1] { expected. [ERROR] C:\m2_repo_clean\com\adobe\flex\framework\spark\4.5.1.21328\spark-4.5.1.21328.swc$defaults.css:[15,-1] { expected. [WARNING] C:\Workspaces\aa_Branches\aa_jdk8_upgrade\flex\src\main\flexapp\APP_MIGRATED.mxml:[0,-1] CSS selector condition type is not supported: ':normalWithPrompt' [WARNING] C:\Workspaces\aa_Branches\aa_jdk8_upgrade\flex\src\main\flexapp\APP_MIGRATED.mxml:[0,-1] CSS selector condition type is not supported: ':disabledWithPrompt'

This is my full pom configuration

<parent>
    <artifactId>app-migrated</artifactId>
    <groupId>com.appmigrated</groupId>
    <version>1.7-SNAPSHOT</version>
</parent>
<modelVersion>4.0.0</modelVersion>
<artifactId>flex</artifactId>
<packaging>pom</packaging>
<name>Flex</name>

<build>
    <finalName>APP_MIGRATED</finalName>
    <sourceDirectory>src/main/flexapp</sourceDirectory>
    <resources>
        <resource>
            <directory>${basedir}/src/main/resources</directory>
        </resource>
        <resource>
            <directory>${basedir}/target/generated-resources</directory>
        </resource>
    </resources>
    <plugins>
        <plugin>
            <groupId>org.sonatype.flexmojos</groupId>
            <artifactId>flexmojos-maven-plugin</artifactId>
            <version>${flex-mojos.version}</version>
            <extensions>true</extensions>
            <executions>
                <execution>
                    <goals>
                        <goal>compile-swf</goal>
                    </goals>
                </execution>
            </executions>
            <configuration>
                <moduleFiles>
                    <module>APP_MIGRATED.mxml</module>
                </moduleFiles>
                <locales>
                    <param>en_US</param>
                </locales>
                <services>${basedir}/src/main/resources/services-config.xml</services> 
                <contextRoot>root</contextRoot>
                <keepAllTypeSelectors>true</keepAllTypeSelectors>
                <output>${basedir}/target/APP_MIGRATED.swf</output>
                <targetPlayer>9.0.0</targetPlayer>
            </configuration>
        </plugin>
        <plugin>
            <groupId>org.sonatype.flexmojos</groupId>
            <artifactId>flexmojos-maven-plugin</artifactId>
            <version>3.2.0</version>
            <executions>
                <execution>
                     <goals>
                        <goal>wrapper</goal>
                    </goals>
                    <phase>generate-resources</phase>
                </execution>
            </executions>
            <configuration>
                <ignoreVersionIssues>true</ignoreVersionIssues>
                 <htmlName>APP_MIGRATED</htmlName>
                 <outputDirectory>${project.build.directory}/html-wrapper</outputDirectory> 
           </configuration>
        </plugin>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-dependency-plugin</artifactId>
            <executions>
                <execution>
                    <id>unpack-config</id>
                    <goals>
                        <goal>unpack-dependencies</goal>
                    </goals>
                    <phase>generate-resources</phase>
                    <configuration>
                        <outputDirectory>${project.build.directory}/generated-resources</outputDirectory>
                        <includeArtifacIds>APP_MIGRATED</includeArtifacIds>
                        <includeGroupIds>${project.groupId}</includeGroupIds>
                        <excludeTransitive>true</excludeTransitive>
                    </configuration>
                </execution>
            </executions>
        </plugin>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-assembly-plugin</artifactId>
            <executions>
                <execution>
                    <id>make.html-bundle</id>
                    <goals>
                        <goal>single</goal>
                    </goals>
                    <phase>package</phase>
                    <configuration>
                        <descriptors>
                            <descriptor>src/main/assembly/html-bundle.xml</descriptor>
                        </descriptors>
                    </configuration>
                </execution>
            </executions>
        </plugin>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-assembly-plugin</artifactId>
            <executions>
                <execution>
                    <id>make.resources</id>
                    <goals>
                        <goal>single</goal>
                    </goals>
                    <phase>package</phase>
                    <configuration>
                        <descriptors>
                            <descriptor>src/main/assembly/resources.xml</descriptor>
                        </descriptors>
                    </configuration>
                </execution>
            </executions>
        </plugin>

    </plugins>
</build>

<properties>
  <flex.sdk.version>4.5.1.21328</flex.sdk.version>
    <flex-mojos.version>4.0-RC2</flex-mojos.version>
</properties>

<dependencies>
    <dependency>
        <groupId>com.adobe.flex.framework</groupId>
        <artifactId>flex-framework</artifactId>
        <version>${flex.sdk.version}</version>
        <type>pom</type>
    </dependency>
    <dependency> 
        <groupId>com.adobe.cairngorm</groupId> 
        <artifactId>cairngorm</artifactId> 
        <version>2.2.1</version> 
        <type>swc</type> 
    </dependency>
</dependencies>

I know maybe there is can be another errors after this one, but this is the one which concerns me more.

Greetings,

Aucun commentaire:

Enregistrer un commentaire